Tutorial de instalação do Zabbix 2.0.0

Olá, amigo(a)!

Fiz os tutoriais abaixo para ajudar a instalar o Zabbix 2.0.0.

Instalando o Zabbix 2.0.0 no Ubuntu 10.04 e 12.04 com PostgreSQL – Aécio Pires

Instalando o Zabbix 2.0.0 no Debian 6 com MySQL – Aécio Pires

Mais novidades sobre o Zabbix 2.0 podem ser encontradas neste post http://zabbixbrasil.org/?p=272 e no site official do Zabbix: http://zabbix.com

Para aprender mais sobre Zabbix, você pode olhar a página Arquivo do site da comunidade Zabbix Brasil http://zabbixbrasil.org/?page_id=7 e o manual http://www.zabbix.com/documentation/2.0/manual

Abraço.

57 ideias sobre “Tutorial de instalação do Zabbix 2.0.0

  • Opa Aécio, muito bom seus tutoriais! Só um detalhe, em ambos existe uma dependência que está errada o nome. No tutorial está como “libiksemeldev”, porém a correta é com o traço: “libiksemel-dev”… Fica a dica! E parabéns pelo blog!

  • Bixo, segui certinho seu tutorial.. mas quando faço o login na interface fica essa mensagem de Zabbix server is running Value No, já ativei o host mas não tem jeito. Poderia me dar uma ajuda? Até!

  • Oi, Nilton!

    Você ainda está passando por este problema? Se sim, me envia um email com os arquivos abaixo para eu entender o problema.

    /etc/init.d/zabbix-agentd
    /etc/init.d/zabbix-server
    /usr/local/etc/zabbix_agentd.conf
    /usr/local/etc/zabbix_server.conf
    /tmp/zabbix_agentd.log
    /tmp/zabbix_server.log

  • Aécio, bom dia…

    Não consegui fazer o download do arquivo de instalação de tutorial para o Ubuntu, teria como me enviar por email (sonsonmc@gmail.com)???

    Estou precisando um tanto urgente!
    Valeu!!!

  • Aécio bom dia,
    Estou com uma dúvida e gostaria que você se possivel me ajude, instalei todas as dependencias, mas ao procurar por ” /etc/postgresql/8.4/main/pg_hba.conf ” mas não estou localizando a pasta/arquivo se eu der um locate pg_hba ele indica um arquivo em “/usr/share/postgresql/8.4/pg_hba.conf.sample”, que não condiz com o arquivo a ser editado.
    se eu tentar instalar novamente, ele mostra que já está tudo instalado.

    “flex is already the newest version.
    gcc is already the newest version.
    libopenipmi-dev is already the newest version.
    fping is already the newest version.
    gpp is already the newest version.
    libiksemel-dev is already the newest version.
    libssh2-1 is already the newest version.
    libssh2-1-dev is already the newest version.
    php-net-socket is already the newest version.
    apache2 is already the newest version.
    curl is already the newest version.
    libapache2-mod-php5 is already the newest version.
    libpq-dev is already the newest version.
    libpq5 is already the newest version.
    libsnmp-dev is already the newest version.
    make is already the newest version.
    php5 is already the newest version.
    php5-gd is already the newest version.
    php5-pgsql is already the newest version.
    postgresql-client is already the newest version.
    snmp is already the newest version.
    vim is already the newest version.
    postgresql-8.4 is already the newest version.
    oracle-java7-installer is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.”

  • Aécio! Primeiro parabéns pelas dicas! Gostaria de sua gentileza em informar se consigo instalar o zabbix numa maquina virtual com ubuntu. Abraço

  • Quando tento executar estes comandos seguindo seu tutorial.

    sudo apt-get install -y –force-yes make flex gcc gpp apache2 php5 php5-pgsql
    postgresql-9.1 libapache2-mod-php5 php5-gd php-net-socket postgresql-client
    libpq5 libpq-dev snmp libiksemel-dev libcurl4-gnutls-dev vim libssh2-1-dev
    libssh2-1 libopenipmi-dev libsnmp-dev oracle-java7-installer curl fping

    Estou recebendo estas mensagens de erro.

    zabbix@zabbix-bnet:~$ sudo apt-get install -y –force-yes make flex gcc gpp apache2 php5 php5-pgsql
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    make já é a versão mais nova.
    flex já é a versão mais nova.
    gcc já é a versão mais nova.
    gpp já é a versão mais nova.
    apache2 já é a versão mais nova.
    php5 já é a versão mais nova.
    php5-pgsql já é a versão mais nova.
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 218 não atualizados.
    zabbix@zabbix-bnet:~$ postgresql-9.1 libapache2-mod-php5 php5-gd php-net-socket postgresql-client
    postgresql-9.1: comando não encontrado
    zabbix@zabbix-bnet:~$ libpq5 libpq-dev snmp libiksemel-dev libcurl4-gnutls-dev vim libssh2-1-dev
    libpq5: comando não encontrado
    zabbix@zabbix-bnet:~$ libssh2-1 libopenipmi-dev libsnmp-dev oracle-java7-installer curl fping
    libssh2-1: comando não encontrado
    zabbix@zabbix-bnet:~$ ^C
    zabbix@zabbix-bnet:~$

    Podes me dar um help..

    sou muito cru em linux, e nao acho ninguem pra ajudar por aqui.

    Grato

     

    Milton Olegario

  • Oi, Milton!

    Este erro está acontecendo porque você está copiando o comando do PDF e colando no terminal. Experimenta olhar o comando no PDF e digitar com calma no terminal. Veja que este comando grande deve estar em uma linha só.

    Dando certo, faça o mesmo para o restante do tutorial.

    Abraço.

  • Aécio, obrigado por postar o tutorial, esta tudo muito bem claro… Se possível, me tire um duvida: na parte do Setup do Zabbix, onde vc tem que que entrar com os dados do banco: Database type, Database host, Database port….. no campo “User” que usuário vc esta se referindo?

    Seria o mesmo usuario do SO?

    Obrigado!!!!

  • Oi, Carlos!

    Obrigado.

    É não. O usuário citado é o do banco de dados, criado conforme mostrado no tutorial e na tela 3 da seção: Acessando a Interface Web.

    Abraço.

  • Aecio, vc se refere a esta parte: ” $ sudo adduser zabbix” ?

    e depois este mesmo usuário e a senha tenho q colocar em “DBuser=” e “DBpassword” do arquivo “zabbix_server.conf”?

  • Oi, Carlos!

    O comando adduser adiciona um usuário ao S.O. Mas abaixo dele tem o comando “sudo -u postgres createuser -a -d -E -P zabbix” que adiciona o usuário zabbix ao PostgreSQL (banco de dados). É a este último ao qual me refiro na tela 3.

    Abraço.

  • Fiz a instalação do zabbix seguindo o tutorial, mas quando procurei os arquivos dentro do diretório o /usr/local/etc, não encontrei nenhum, o que aconteceu?

     

  • O tutorial é muito bom, mas estou enfrentando um erro,e não achei nada a respeito.

    Após criar o usuario a um comando -u, e ele me responde: -u command not found.

  • Oi, Heider!

     

    Isso já aconteceu antes e acredito que houve algum erro na execução do tutorial.

    Refaça tudo com calma e paciência. Preste bem atenção quando estiver copiando e colando os comandos e, de preferência, não copie e cole os comandos, mas digite-os manualmente para evitar que os comandos sejam colados em “linhas quebradas”.

     

    Abraço.

  • Oi, Douglas!

     

    É a primeira vez que vejo este erro. Deve ter tido algum problema ao copiar/colar os comandos. Sugiro que digite-os manualmente com calma e paciência. Você está usando o Ubuntu 10.04 ou 12.04, né?

     

    Abraço.

  • Boa noite Aécio, primeiramente meus parabéns pelo seu tutorial, pois está indo tudo do jeito que você colocou, mas fiquei com uma dúvida, o que representa o comando “\q” nessa linha de código postgres=# \q; ?

    e também quando criei um usuario no $ sudo adduser zabbix, foi tranquilo, mas quando cheguei no próximo código $ sudo -u postgres createuser -a -d -E -P zabbix, aí fiquei com muita dúvida, pois sem isso não consigo passar na parte 3 da instalação do zabbix … desde já agradeço !!!

  • Aécio, consegui achar o erro em questão do bando de dados !! Parabéns pelo seu tutorial, pois deu tudo certo …. vlw brother !! 🙂

  • Aécio, parabéns execelente tutorial!! deu tudo certo!!! você já fez algum tutorial sobre como configurar? um abraço

  • Bom dia, Aécio. Muito bom o tutorial, fiz a instalação no VMWare a versão do Ubuntu que usei foi a 13.04, executei todo o tutorial e a instalação ocorreu corretamente, porém quando acesso o no Web Browser – Firefox, em Monitoring-Dashboard – Server Zabbix is running (no) e a mensagem que mostra é  “Zabbix server is not running: the information displayed may not be current.” Já desabilitei o firewall, antivirus… e nada de rodar. O que faço para funcionar?

  • Bom dia, Tiago e Rannieri!

     

    Se ainda continuam com esse problema, enviem para o meu email os arquivos abaixo para eu entender o problema.

     

    /etc/init.d/zabbix-agentd
    /etc/init.d/zabbix-server
    /usr/local/etc/zabbix_agentd.conf
    /usr/local/etc/zabbix_server.conf
    /tmp/zabbix_agentd.log
    /tmp/zabbix_server.log

  • Olá Aécio , parabéns pelo seu tutorial , esclareceu muitas duvidas que tinha , só uma pergunta , posso usar esse tutorial com o Debian 7 ?

    Desde de já agradeço a atenção.

  • Aecio, boa tarde.

    Como faço para acessar o Zabbix fora da rede pois a porta 80 já esta com acesso ao roteador de entrada.

    Sei que tenho que fazer um nat para outra porta (EX. 8080) apontando para o servidor.

    A duvida é – Altero alguma coisa no servidor do Zabbix.

    Desde já obrigado!

  • Bom dia segui seu tutorial a finco, apenas mudei a versão da instalação do zabbix que no seu tutorial 2.0.9, eu usei a 2.4.3 ok.
    Quando vou executar o Make Install  na instalação aparece a seguinte mensagem.

    make: *** Sem regra para processar o alvo ‘instal’. Pare

     

    Por Favor pode me dar uma orientação

     

    Grato

     

     

  • Oi, Adilson!

     

    Pela mensagem de erro, o comando que você digitou foi “make instal” ou make “install”?

  • detalhe já dei o comando chmod 777 na pasta zabbix 2.4.3 por via das duvídas mais continua o mesmo erro :/

  • Adilson, será que você não pulou a parte em que o “./configure” com seus parâmetros era executado dentro da pasta com os arquivos fontes do Zabbix? Se não pulou, será que não houve algum erro por faltar algum pacote necessário para a compilação? Em qual distro e versão você está executando a instalação?

  • OI Aécio executei o ./configure dentro da pasta do zabbix blz ai apareceu uma tela assim

    Configuration

    Deteceted OS Linux-gnu

    install patch /usr/local

    compilation arch linux

    compiler gcc

    compiler flag -g -02

    enabel server no

    proxy no

    agent no

    java gateway no

    ldap no

    ipv6 no

    Now run ‘ make install’

     

    thank you for zabbix

     

    ai quando rodo o meke install aparece uma serie de comando que dizem :

    entrando no diretório /home/ adilson/zabbix-2.4.3/man

    nada a ser feito para install-exec-am, isso ocorre umas 15 vezes ai para com o prompt da pasta do zabbix.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *